Folge xaranshop auf Facebook

xaranshop® - Die Onlineshop Software für kleine und mittelständische Unternehmen.

            « Zurück
Host Europe informiert: Information zur geplanten Deaktivierung von PHP 5.3
xaranshop® V4.0
Konfiguration und Einrichtung

Name: Peter Reiss          peter (ατ) mindandmagic.de          http://www.mindandmagic.de/magicshop/
Datum: 08.10.2015 23:18:44

  Host Europe schreibt heute in einer Mail (Hervorhebungen von mir):

... im Kundeninfomationssytem (KIS) bieten wir Ihnen die Möglichkeit, Ihre Anwendungen mit unterschiedlichen PHP-Versionen (verfügbar sind aktuell PHP 5.3, PHP 5.4, PHP 5.5) zu betreiben.

Da PHP ständig weiterentwickelt wird und alte Versionen ab einem gewissen Zeitpunkt nicht mehr unterstützt werden, ist es auch im Bereich des Webhosting notwendig, regelmäßig die PHP-Versionen auszutauschen, um die Server / WebHosting Pakete auf einen aktuellen Stand zu bringen bzw. zu halten.

In Ihrem Produkt verwendet aktuell mindestens ein Verzeichnis (VHOST)/ eine Domain die inzwischen nicht mehr aktuelle Version PHP 5.3. Die Version PHP 5.3 werden wir am 16.02.2016 deaktivieren, so dass eine Umstellung auf die neuere Version PHP 5.5 notwendig ist. Wir empfehlen Ihnen, die Umstellung auf PHP 5.5 zu testen und in den nächsten Wochen vorzunehmen...


Die Produktdetails xaranshop 4.0 sagen:
Systemvoraussetzungen beim Webprovider:
PHP 5.2.2 oder höher


Was ist zu tun?

Beste Grüße
Peter Reiss
 
  Thomas Görtler antwortet am 09.10.2015 09:32:01
Hallo Herr Reis,

vielen Dank für Ihre Nachricht.

Aktuell arbeite ich an einer neuen Version für den xaranshop 5. Die neue Version wird voraussichtlich Mitte November verfügbar sein.

Danach prüfe ich den xaranshop 4 auf Fehler/Probleme mit PHP 5.5. Das sollte wesentlich einfacher anzupassen sein als der xaranshop 5. Dort müssen sämtliche Datenbank Methoden getauscht und getestet werden, da es dann die bisherigen PHP Befehle unter PHP 5.5 nicht mehr gibt.

Es wird also zeitnah vor der Umstellung auf PHP 5.5 für beide Programme eine neue Version geben.

Freundliche Grüße,
Thomas Görtler
 info (ατ) punktsoft.de         http://www.punktsoft.de
  Ralf Ehlers antwortet am 10.10.2015 11:14:56
Hallo Herr Görtler,

ich lese soeben, dass Sie ein paar Anpassungen auch im X4 vornehmen werden. Ich möchte anregen, dass Sie 3 generelle Änderungen vornehmen, die ich als wichtig erachte:

Vorlage unterhalb: Bitte den Link zu Ihrer Seite mit *target="_blank"* ergänzen.

Vorlage artikelauswahl und artikeldetails: Hier bitte jeweils den Buttontext von "bestellen" auf "in den Warenkorb" ändern. (Dieses dann auch bitte im X5 - für alle Nutzer)

Der letzte Punkt wurde bei der Zertifizierung unseres Shops http://fashiontraeume.de durch den Händlerbund reklamiert.

Vielleicht ist es ja besser den früher gängigen Begriff "bestellen" nicht mehr zu favorisieren.

Mit freundlichen Grüßen

Ralf Ehlers
 kontakt (ατ) wohnenundmehr.de         http://claudia-ehlers.de
  T Schlüter antwortet am 02.02.2016 19:59:23
Hallo Herr Görtler,

in Kürze wird nun die PHP-Version 5.3, wie oben beschrieben, abgeschaltet. Unterstützt die neue Version 4.0.10.0 bereits die neuen PHP-Versionen? In der Update-Beschreibung ist leider nichts ersichtlich.

MfG
T. Schlüter
 webmaster (ατ) kultundfun.de
  Thomas Görtler antwortet am 03.02.2016 08:47:10
Hallo Herr Schlüter,
im Laufe der Woche wird es eine getestete Version 4 zu dieser Problematik geben. Aktuell kann ich noch nicht sagen ob alle Funktionen PHP 5.6 kompatibel sind. Die Umstellung wird voraussichtlich nicht so große Dimensionen wie bei Version 5 annehmen, da in Version 4 keine Datenbankanbindung vorhanden ist.
Freundliche Grüße,
Thomas Görtler
 info (ατ) punktsoft.de         http://www.punktsoft.de

Beitrag 1 Antwort zu diesem Beitrag schreiben
 
 

Alle Urheber- und Leistungsschutzrechte vorbehalten. © punkt Software Development 2012-2022
Dieses Angebot ist ausschließlich für Industrie, Handwerk, Handel, öffentliche Einrichtungen und die freien Berufe bestimmt
Diese Webseite wurde mit xaranshop® 5.0 erstellt
xaran® und xaranshop® sind eingetragene Markenzeichen